<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Edward J. Cabral, 80 - Local Headline News</title>
<!--[ADSENSE CODE]><!--> 
<script data-ad-client="ca-pub-1171910892658964" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<link href='http://fonts.googleapis.com/css?family=Droid+Sans:regular,bold' rel='stylesheet' type='text/css' />

<link href='http://fonts.googleapis.com/css?family=OFL+Sorts+Mill+Goudy+TT:regular,italic&subset=latin' rel='stylesheet' type='text/css'/>

<link rel="stylesheet" href="https://localheadlinenews.com/wp-content/themes/Magnificent/style.css" type="text/css" media="screen" />
<link rel="pingback" href="https://localheadlinenews.com/xmlrpc.php" />

<!--[if lt IE 7]>
	<link rel="stylesheet" type="text/css" href="https://localheadlinenews.com/wp-content/themes/Magnificent/css/ie6style.css" />
	<script type="text/javascript" src="https://localheadlinenews.com/wp-content/themes/Magnificent/js/DD_belatedPNG_0.0.8a-min.js"></script>
	<script type="text/javascript">DD_belatedPNG.fix('img#logo, p#slogan, #menu, #top-overlay, #featured-overlay, span.overlay, .entry-content p.meta-info, #controllers span#right-arrow, #controllers span#left-arrow, #footer-content, #footer');</script>
<![endif]-->
<!--[if IE 7]>
	<link rel="stylesheet" type="text/css" href="https://localheadlinenews.com/wp-content/themes/Magnificent/css/ie7style.css" />
<![endif]-->
<!--[if IE 8]>
	<link rel="stylesheet" type="text/css" href="https://localheadlinenews.com/wp-content/themes/Magnificent/css/ie8style.css" />
<![endif]-->

<script type="text/javascript">
	document.documentElement.className = 'js';
</script>

<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Edward J. Cabral, 80 - Local Headline News" />
	<meta property="og:description" content="Published June 25, 2021 MELROSE — Edward J. Cabral, of Melrose, passed away on June 20, 2021 at the age of 80. Ed was born on June 7, 1941 to Jesse and Lillian (Rice) Cabral. He was raised in Malden and graduated from Malden High School in 1949. Ed worked in insurance for many years. [&hellip;]" />
	<meta property="og:url" content="https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/" />
	<meta property="og:site_name" content="Local Headline News" />
	<meta property="article:publisher" content="https://www.facebook.com/wakefield.dailyitem" />
	<meta property="article:published_time" content="2021-06-24T17:35:55+00:00" />
	<meta property="article:modified_time" content="2021-06-24T17:35:56+00:00" />
	<meta property="og:image" content="https://localheadlinenews.com/wp-content/uploads/2021/06/obit-edward-j-cabral-web.jpg" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@WakefieldDaily" />
	<meta name="twitter:site" content="@WakefieldDaily" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="jkeating624">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="2 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://localheadlinenews.com/#website","url":"https://localheadlinenews.com/","name":"Local Headline News","description":"Serving Wakefield, Melrose, Lynnfield and North Reading Massachusetts","potentialAction":[{"@type":"SearchAction","target":"https://localheadlinenews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/#primaryimage","inLanguage":"en-US","url":"https://localheadlinenews.com/wp-content/uploads/2021/06/obit-edward-j-cabral-web.jpg","contentUrl":"https://localheadlinenews.com/wp-content/uploads/2021/06/obit-edward-j-cabral-web.jpg","width":150,"height":225},{"@type":"WebPage","@id":"https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/#webpage","url":"https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/","name":"Edward J. Cabral, 80 - Local Headline News","isPartOf":{"@id":"https://localheadlinenews.com/#website"},"primaryImageOfPage":{"@id":"https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/#primaryimage"},"datePublished":"2021-06-24T17:35:55+00:00","dateModified":"2021-06-24T17:35:56+00:00","author":{"@id":"https://localheadlinenews.com/#/schema/person/2df790b32e7539ac2ff2de4ddb6a376f"},"breadcrumb":{"@id":"https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/"]}]},{"@type":"BreadcrumbList","@id":"https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://localheadlinenews.com/","url":"https://localheadlinenews.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/","url":"https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/","name":"Edward J. Cabral, 80"}}]},{"@type":"Person","@id":"https://localheadlinenews.com/#/schema/person/2df790b32e7539ac2ff2de4ddb6a376f","name":"jkeating624","image":{"@type":"ImageObject","@id":"https://localheadlinenews.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/342b5ad6f9d421c6888004ae332f3359?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/342b5ad6f9d421c6888004ae332f3359?s=96&d=mm&r=g","caption":"jkeating624"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Local Headline News &raquo; Feed" href="https://localheadlinenews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Local Headline News &raquo; Comments Feed" href="https://localheadlinenews.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/localheadlinenews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=b261fbcf7c892563c5f10e7924fb6b8e"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Magnificent v.3.7" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://localheadlinenews.com/wp-includes/css/dist/block-library/style.min.css?ver=b261fbcf7c892563c5f10e7924fb6b8e' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='theme-my-login-css'  href='https://localheadlinenews.com/wp-content/plugins/theme-my-login/assets/styles/theme-my-login.min.css?ver=7.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='et-shortcodes-css-css'  href='https://localheadlinenews.com/wp-content/themes/Magnificent/epanel/shortcodes/css/shortcodes.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://localheadlinenews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='https://localheadlinenews.com/wp-content/themes/Magnificent/epanel/page_templates/js/fancybox/jquery.fancybox-1.3.4.css?ver=1.3.4' type='text/css' media='screen' />
<link rel='stylesheet' id='et_page_templates-css'  href='https://localheadlinenews.com/wp-content/themes/Magnificent/epanel/page_templates/page_templates.css?ver=1.8' type='text/css' media='screen' />
<script type='text/javascript' src='https://localheadlinenews.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://localheadlinenews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://localheadlinenews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://localheadlinenews.com/wp-json/wp/v2/posts/92849" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://localheadlinenews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://localheadlinenews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://localheadlinenews.com/?p=92849' />
<link rel="alternate" type="application/json+oembed" href="https://localheadlinenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flocalheadlinenews.com%2Fmelrose-weekly-news-obituary-edward-j-cabral-80%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://localheadlinenews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flocalheadlinenews.com%2Fmelrose-weekly-news-obituary-edward-j-cabral-80%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.18 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<style type='text/css'>img#wpstats{display:none}</style>
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-59716263-1', 'auto');
  ga('send', 'pageview');

</script>
<style>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</style>				<style id="uagb-style-conditional-extension">@media (min-width: 1025px){.entry-content .uag-hide-desktop.uagb-google-map__wrap,.entry-content .uag-hide-desktop{display:none}}@media (min-width: 768px) and (max-width: 1024px){.entry-content .uag-hide-tab.uagb-google-map__wrap,.entry-content .uag-hide-tab{display:none}}@media (max-width: 767px){.entry-content .uag-hide-mob.uagb-google-map__wrap,.entry-content .uag-hide-mob{display:none}}</style>
				<style type="text/css">
		#et_pt_portfolio_gallery { margin-left: -11px; }
		.et_pt_portfolio_item { margin-left: 23px; }
		.et_portfolio_small { margin-left: -39px !important; }
		.et_portfolio_small .et_pt_portfolio_item { margin-left: 34px !important; }
		.et_portfolio_large { margin-left: -20px !important; }
		.et_portfolio_large .et_pt_portfolio_item { margin-left: 14px !important; }
	</style>
		<style type="text/css" id="wp-custom-css">
			section.slide_block {
	float:left;
	width:718px;
	height:100%;
	padding: 0 0 8px 0;
	margin: 0;
}

section.slide_block .wp-block-jetpack-slideshow_caption.gallery-caption {
	text-align:center;
	font-size:14px;
}		</style>
		</head>
<body class="post-template-default single single-post postid-92849 single-format-standard gecko et_includes_sidebar">

<div id="wrapper">

<div id="topbar">

	<ul class="left-bar">
	<li><a href="https://localheadlinenews.com/"><span id="site_title">Local Headline News</span><span id="slogan"> - North of Boston News</span></a></li>
	<li><a href="https://localheadlinenews.com/about-us">About Us</a></li>
	<li><a href="https://localheadlinenews.com/contact-us">Contact Us</a></li>
	</ul>

	<ul class="right-bar">
	<li>
	<div id="admin-right">
	<div id="search-3" class="widget widget_search"> <form method="get" id="searchform" action="https://localheadlinenews.com//">
    <div>
        <input type="text" value="" name="s" id="s" />
        <input type="submit" id="searchsubmit" value="Search" />
    </div>
</form></div>	</div>
	</li>
	<li>
		<a href="https://localheadlinenews.com/subscription">Subscribe</a>
		</li>
	</ul>

</div>

<div id="site-container">

		<div id="menu">
			<div class="container clearfix">
				<ul id="primary" class="nav"><li id="menu-item-121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-121"><a title="Wakefield Daily Item" href="https://localheadlinenews.com/wakefield-daily-item-2/"><img src="https://localheadlinenews.com/wp-content/themes/Magnificent/images/WDI_nav.png" width="226" height="65" border="0" /></a>
<ul class="sub-menu">
	<li id="menu-item-146" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146"><a href="https://localheadlinenews.com/wakefield-news/">News</a></li>
	<li id="menu-item-145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145"><a href="https://localheadlinenews.com/wakefield-sports/">Sports</a></li>
	<li id="menu-item-144" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-144"><a href="https://localheadlinenews.com/wakefield-obituaries/">Obituaries</a></li>
	<li id="menu-item-33030" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33030"><a href="https://localheadlinenews.com/wakefield-legal-notices/">Legal Notices</a></li>
	<li id="menu-item-41799" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41799"><a href="https://localheadlinenews.com/wakefield-real-estate/">Real Estate</a></li>
	<li id="menu-item-44667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44667"><a href="https://localheadlinenews.com/subscription/">Subscribe</a></li>
</ul>
</li>
<li id="menu-item-179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-179"><a title="North Reading Transcript" href="https://localheadlinenews.com/north-reading-transcript-2/"><img src="https://localheadlinenews.com/wp-content/themes/Magnificent/images/NRT_nav.png" width="226" height="65" border="0" /></a>
<ul class="sub-menu">
	<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://localheadlinenews.com/north-reading-news/">News</a></li>
	<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://localheadlinenews.com/north-reading-sports/">Sports</a></li>
	<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://localheadlinenews.com/north-reading-obituaries/">Obituaries</a></li>
	<li id="menu-item-33031" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33031"><a href="https://localheadlinenews.com/north-reading-legal-notices/">Legal Notices</a></li>
	<li id="menu-item-41798" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41798"><a href="https://localheadlinenews.com/north-reading-real-estate/">Real Estate</a></li>
	<li id="menu-item-44670" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44670"><a href="https://localheadlinenews.com/subscription/">Subscribe</a></li>
</ul>
</li>
<li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-134"><a title="Melrose Weekly News" href="https://localheadlinenews.com/melrose-weekly-news-2/"><img src="https://localheadlinenews.com/wp-content/themes/Magnificent/images/MWN_nav_2.png" width="226" height="65" border="0" /></a>
<ul class="sub-menu">
	<li id="menu-item-174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174"><a href="https://localheadlinenews.com/melrose-news/">News</a></li>
	<li id="menu-item-173" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-173"><a href="https://localheadlinenews.com/melrose-sports/">Sports</a></li>
	<li id="menu-item-172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-172"><a href="https://localheadlinenews.com/melrose-obituaries/">Obituaries</a></li>
	<li id="menu-item-33032" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33032"><a href="https://localheadlinenews.com/melrose-legal-notices/">Legal Notices</a></li>
	<li id="menu-item-41797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41797"><a href="https://localheadlinenews.com/melrose-real-estate/">Real Estate</a></li>
	<li id="menu-item-44669" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44669"><a href="https://localheadlinenews.com/subscription/">Subscribe</a></li>
</ul>
</li>
<li id="menu-item-42" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-42"><a title="Lynnfield Villager" href="https://localheadlinenews.com/lynnfield-villager/"><img src="https://localheadlinenews.com/wp-content/themes/Magnificent/images/LV_nav.png" width="226" height="65" border="0" /></a>
<ul class="sub-menu">
	<li id="menu-item-46546" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46546"><a href="https://localheadlinenews.com/lynnfield-news/">News</a></li>
	<li id="menu-item-170" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170"><a href="https://localheadlinenews.com/lynnfield-sports/">Sports</a></li>
	<li id="menu-item-169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-169"><a href="https://localheadlinenews.com/lynnfield-obituaries/">Obituaries</a></li>
	<li id="menu-item-33033" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33033"><a href="https://localheadlinenews.com/lynnfield-legal-notices/">Legal Notices</a></li>
	<li id="menu-item-41796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41796"><a href="https://localheadlinenews.com/lynnfield-real-estate/">Real Estate</a></li>
	<li id="menu-item-44668" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44668"><a href="https://localheadlinenews.com/subscription/">Subscribe</a></li>
</ul>
</li>
</ul>			</div> <!-- end .container -->
		</div> <!-- end #menu -->

	<div id="header">
		<div class="container">

<div id="header-left">

	
	<div class="pre-widget">
		<p></p>
	</div>

	
</div>

<div id="header-right">

	
	<div class="pre-widget">
		<p></p>
	</div>

	
</div>

<div id="banner-area">

	<div id="text-11" class="widget widget_text"> 			<div class="textwidget"><div class="g g-1"><div class="g-single a-11"><a class="gofollow" data-track="MTEsMSwxLDYw" href="https://melrosema.com/"><img src="https://localheadlinenews.com/wp-content/uploads/2014/10/bradopenhouses_728x901.png" alt="" class="header-ad" /></a></div></div>
</div>
		</div>
</div>

			</div> <!-- end .container -->
		</div> <!-- end #header -->
		<div id="newspaper_logo" align="center"><img src="https://www.localheadlinenews.com/wp-content/themes/Magnificent/images/MWNlogotag_transparent.png" width="680" alt="Melrose Weekly News" /></div>		<div id="content">
			<div class="container clearfix">

<div id="breadcrumbs">

					<a href="https://localheadlinenews.com/">Home</a> <span class="raquo">&raquo;</span>

									<a href="https://localheadlinenews.com/category/melrose-obituaries/">Melrose Obituaries</a> <span class="raquo">&raquo;</span> Edward J. Cabral, 80					
</div> <!-- end #breadcrumbs -->

	<div id="entries">
		<div class="entry post entry-full">
			<div class="border">
				<div class="bottom">
					<div class="entry-content clearfix nobottom">
						<h1 class="title">Edward J. Cabral, 80</h1>
						<p class="meta-info">Jun 24, 2021 <span>by</span> <a href="https://localheadlinenews.com/author/jkeating624/" title="Posts by jkeating624" rel="author">jkeating624</a></p>

						
							
							
						
						
<p class="has-text-align-center">Published June 25, 2021</p>



<div class="wp-block-image"><figure class="alignleft size-large"><img loading="lazy" width="150" height="225" src="https://localheadlinenews.com/wp-content/uploads/2021/06/obit-edward-j-cabral-web.jpg" alt="" class="wp-image-92825" srcset="https://localheadlinenews.com/wp-content/uploads/2021/06/obit-edward-j-cabral-web.jpg 150w, https://localheadlinenews.com/wp-content/uploads/2021/06/obit-edward-j-cabral-web-100x150.jpg 100w" sizes="(max-width: 150px) 100vw, 150px" /></figure></div>



<p>MELROSE — Edward J. Cabral, of Melrose, passed away on June 20, 2021 at the age of 80. Ed was born on June 7, 1941 to Jesse and Lillian (Rice) Cabral. He was raised in Malden and graduated from Malden High School in 1949. Ed worked in insurance for many years. He was a loving grandfather who enjoyed spending time with his grandchildren; he was very proud of them all.</p>



<p>Ed was the beloved husband of the late Joan M. (Killam) Cabral. Loving father of James E. Cabral of Malden, and Catherine E. Leonard her husband, Steven, of Stoneham. Proud grandfather of Bryce and Samantha Leonard, and Elizabeth Bennett. Visiting hours will be held at the Gately Funeral Home, 79 W. Foster St., Melrose, on Sunday, June 27, 2021 from 2 &#8211; 6 p.m. A graveside prayer service will be held at Wyoming Cemetery, 205 Sylvan St., Melrose, on Monday, June 28 at 11 a.m. Pull in the main gate of the cemetery just before 11 a.m. to join the funeral procession to the gravesite. Relatives and friends are respectfully invited to attend. In lieu of flowers, contributions in Ed’s memory may be made to the American Heart Association, PO Box 840692, Dallas, TX 75284-0692 or at https://www.heart.org/ . To leave an online message of condolence please visit <a href="https://www.gatelyfh.com/">gatelyfh.com</a>.</p>
												
						<div class="clear"></div>

						<div class="info-panel clearfix">
							<div class="info-block">
	<h3 class="infotitle">Related Posts</h3>
	<div class="ul-thumb">
			</div> <!-- end .ul-thumb -->
</div> <!-- end .info-block -->

<div class="info-block">
	<h3 class="infotitle">Tags</h3>
	<div class="tags clearfix">
			</div> <!-- end .tags -->
</div> <!-- end .info-block -->

<div class="info-block last">
	<h3 class="infotitle">Share This</h3>
	<div class="share-panel">
				<a href="http://twitter.com/home?status=Edward J. Cabral, 80 https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/"><img src="https://localheadlinenews.com/wp-content/themes/Magnificent/images/twitter.png" alt="" /></a>
		<a href="http://www.facebook.com/sharer.php?u=https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/&t=Edward J. Cabral, 80" target="_blank"><img src="https://localheadlinenews.com/wp-content/themes/Magnificent/images/facebook.png" alt="" /></a>
		<a href="http://del.icio.us/post?url=https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/&amp;title=Edward J. Cabral, 80" target="_blank"><img src="https://localheadlinenews.com/wp-content/themes/Magnificent/images/delicious.png" alt="" /></a>
		<a href="http://www.digg.com/submit?phase=2&amp;url=https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/&amp;title=Edward J. Cabral, 80" target="_blank"><img src="https://localheadlinenews.com/wp-content/themes/Magnificent/images/digg.png" alt="" /></a>
		<a href="http://www.reddit.com/submit?url=https://localheadlinenews.com/melrose-weekly-news-obituary-edward-j-cabral-80/&amp;title=Edward J. Cabral, 80" target="_blank"><img src="https://localheadlinenews.com/wp-content/themes/Magnificent/images/reddit.png" alt="" /></a>
	</div> <!-- end .share-panel -->
</div> <!-- end .info-block -->						</div> <!-- end .info-panel -->
					</div> <!-- end .entry-content -->
				</div> <!-- end .bottom -->
			</div> <!-- end .border -->
		</div> <!-- end .entry -->

		<div class="clear"></div>

		
		
		<!-- You can start editing here. -->

<div id="comment-wrap">
	<div id="comment-bottom-bg">

				   <div id="comment-section" class="nocomments">
			  				 <!-- If comments are closed. -->
					<div id="respond">

					</div> <!-- end respond div -->
			  		   </div>
				
			</div>
</div>
	</div> <!-- end #entries -->


		<div id="sidebar-right" class="sidebar">
			<div class="block">
				<div id="sidebar-banner-1" class="sidebar-right-border">
					<div class="block-content">
						<div id="text-10" class="widget widget_text"> 			<div class="textwidget"><div class="g g-2"><div class="g-single a-3"><a class="gofollow" data-track="MywyLDEsNjA=" href="https://www.farrellyrealtygroup.com/"><img src="https://localheadlinenews.com/wp-content/uploads/2020/12/FRG_transcript_sidebar_2020_200px.png" alt="" class="sidebar-ad" /></a></div></div>
</div>
		</div><!-- end .widget -->					</div> <!-- end .block-content -->
				</div> <!-- end .sidebar-right-border -->
			</div> <!-- end .block -->

			<div class="block">
				<div id="sidebar-banner-2" class="sidebar-right-border">
					<div class="block-content">
						<div id="text-12" class="widget widget_text"> 			<div class="textwidget"><div class="g g-3"><div class="g-single a-4"><a class="gofollow" data-track="NCwzLDEsNjA=" href="https://quinlanmemorials.com/home/1939596"><img src="https://localheadlinenews.com/wp-content/uploads/2015/02/quinlanmemorials_200.png" alt="" class="sidebar-ad" /></a></div></div>
</div>
		</div><!-- end .widget -->					</div> <!-- end .block-content -->
				</div> <!-- end .sidebar-right-border -->
			</div> <!-- end .block -->

			<div class="block">
				<div id="sidebar-banner-3" class="sidebar-right-border">
					<div class="block-content">
						<div id="text-13" class="widget widget_text"> 			<div class="textwidget"><div class="g g-4"><div class="g-single a-14"><a class="gofollow" data-track="MTQsNCwxLDYw" href="https://www.parkstreetvet.com"><img src="https://localheadlinenews.com/wp-content/uploads/2014/09/ParkStVet_200x2001.png" alt="" class="sidebar-ad" /></a>
</div></div>
</div>
		</div><!-- end .widget -->					</div> <!-- end .block-content -->
				</div> <!-- end .sidebar-right-border -->
			</div> <!-- end .block -->

			<div class="block">
				<div id="sidebar-banner-4" class="sidebar-right-border">
					<div class="block-content">
						<div id="text-14" class="widget widget_text"> 			<div class="textwidget"><div class="g g-5"><div class="g-single a-15"><a class="gofollow" data-track="MTUsNSwxLDYw" href="https://www.cotafuneralhomes.com/"><img src="https://localheadlinenews.com/wp-content/uploads/2014/10/101714_ourfamily_200x2001.png" alt="" class="sidebar-ad" /></a></div></div>
</div>
		</div><!-- end .widget -->					</div> <!-- end .block-content -->
				</div> <!-- end .sidebar-right-border -->
			</div> <!-- end .block -->

			<div class="block">
				<div class="sidebar-right-border">
					<div class="block-content">
						<div id="archives-2" class="widget widget_archive"><h4 class="widgettitle">Archives</h4><div class="widgetcontent">
			<ul>
					<li><a href='https://localheadlinenews.com/2021/06/'>June 2021</a></li>
	<li><a href='https://localheadlinenews.com/2021/05/'>May 2021</a></li>
	<li><a href='https://localheadlinenews.com/2021/04/'>April 2021</a></li>
	<li><a href='https://localheadlinenews.com/2021/03/'>March 2021</a></li>
	<li><a href='https://localheadlinenews.com/2021/02/'>February 2021</a></li>
	<li><a href='https://localheadlinenews.com/2021/01/'>January 2021</a></li>
	<li><a href='https://localheadlinenews.com/2020/12/'>December 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/11/'>November 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/10/'>October 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/09/'>September 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/08/'>August 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/07/'>July 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/06/'>June 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/05/'>May 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/04/'>April 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/03/'>March 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/02/'>February 2020</a></li>
	<li><a href='https://localheadlinenews.com/2020/01/'>January 2020</a></li>
	<li><a href='https://localheadlinenews.com/2019/12/'>December 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/11/'>November 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/10/'>October 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/09/'>September 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/08/'>August 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/07/'>July 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/06/'>June 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/05/'>May 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/04/'>April 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/03/'>March 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/02/'>February 2019</a></li>
	<li><a href='https://localheadlinenews.com/2019/01/'>January 2019</a></li>
	<li><a href='https://localheadlinenews.com/2018/12/'>December 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/11/'>November 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/10/'>October 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/09/'>September 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/08/'>August 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/07/'>July 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/06/'>June 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/05/'>May 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/04/'>April 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/03/'>March 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/02/'>February 2018</a></li>
	<li><a href='https://localheadlinenews.com/2018/01/'>January 2018</a></li>
	<li><a href='https://localheadlinenews.com/2017/12/'>December 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/11/'>November 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/10/'>October 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/09/'>September 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/08/'>August 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/07/'>July 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/06/'>June 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/05/'>May 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/04/'>April 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/03/'>March 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/02/'>February 2017</a></li>
	<li><a href='https://localheadlinenews.com/2017/01/'>January 2017</a></li>
	<li><a href='https://localheadlinenews.com/2016/12/'>December 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/11/'>November 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/10/'>October 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/09/'>September 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/08/'>August 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/07/'>July 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/06/'>June 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/05/'>May 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/04/'>April 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/03/'>March 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/02/'>February 2016</a></li>
	<li><a href='https://localheadlinenews.com/2016/01/'>January 2016</a></li>
	<li><a href='https://localheadlinenews.com/2015/12/'>December 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/11/'>November 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/10/'>October 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/09/'>September 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/08/'>August 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/07/'>July 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/06/'>June 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/05/'>May 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/04/'>April 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/03/'>March 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/02/'>February 2015</a></li>
	<li><a href='https://localheadlinenews.com/2015/01/'>January 2015</a></li>
	<li><a href='https://localheadlinenews.com/2014/12/'>December 2014</a></li>
	<li><a href='https://localheadlinenews.com/2014/11/'>November 2014</a></li>
	<li><a href='https://localheadlinenews.com/2014/10/'>October 2014</a></li>
	<li><a href='https://localheadlinenews.com/2014/09/'>September 2014</a></li>
			</ul>

			</div></div><!-- end .widget --><div id="recent-comments-2" class="widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><div class="widgetcontent"><ul id="recentcomments"></ul></div></div><!-- end .widget -->					</div> <!-- end .block-content -->
				</div> <!-- end .sidebar-right-border -->
			</div> <!-- end .block -->
		</div> <!-- end #sidebar-right -->

			</div> <!-- end .container -->
		</div> <!-- end #content -->

		<div id="footer" class="clearfix">
			<div id="footer-content">
				<div class="container">
					<div id="text-6" class="footer-widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><div class="row1">
<a href="/">Home</a>
<a href="../?page_id=2687" class="left">About Us</a>
<a href="../?page_id=314" class="left">Contact Us</a>
</div>
<p id="copyright">
&copy 2021 <b>Local Headline News.</b> All rights reserved. | Website Managed by <a href="https://bostonwebgroup.com/" title="Boston Web Design" target="_blank" rel="noopener">Boston Web Group</a>
</p></div>
		</div> <!-- end .footer-widget -->
				</div> <!-- end .container -->

			</div> <!-- end #footer-content -->
		</div> <!-- end #footer -->
	</div> <!-- end #site-container -->
</div> <!-- end #wrapper -->

	
	<script type="text/javascript" src="https://localheadlinenews.com/wp-content/themes/Magnificent/js/jquery.cycle.all.min.js"></script>
	<script type="text/javascript" src="https://localheadlinenews.com/wp-content/themes/Magnificent/js/jquery.easing.1.3.js"></script>
	<script type="text/javascript" src="https://localheadlinenews.com/wp-content/themes/Magnificent/js/superfish.js"></script>


	<script type="text/javascript">
	//<![CDATA[
		jQuery.noConflict();

		jQuery(document).ready(function(){
			jQuery('ul.nav').superfish({
				delay:       300,                            // one second delay on mouseout
				animation:   {opacity:'show',height:'show'},  // fade-in and slide-down animation
				speed:       'fast',                          // faster animation speed
				autoArrows:  true,                           // disable generation of arrow mark-up
				dropShadows: false                            // disable drop shadows
			});

			jQuery('ul.nav > li > a.sf-with-ul').parent('li').addClass('sf-ul');

			et_search_bar();

			var $featured_content = jQuery('#slides');

			jQuery(window).load( function(){
				if ($featured_content.length) {
					$featured_content.css( 'backgroundImage', 'none' );
					$featured_content.cycle({
													timeout: 4000						,
												speed: 500,
						cleartypeNoBg: true,
						prev:   '#featured a#left-arrow',
						next:   '#featured a#right-arrow'
					});

					if ( $featured_content.find('.slide').length == 1 ){
						$featured_content.find('.slide').css({'position':'absolute','top':'8px','left':'8px'}).show();
					}
				}
			} );

			<!---- Search Bar Improvements ---->
			function et_search_bar(){
				var $searchform = jQuery('div#search-form'),
					$searchinput = $searchform.find("input#searchinput"),
					searchvalue = $searchinput.val();

				$searchinput.focus(function(){
					if (jQuery(this).val() === searchvalue) jQuery(this).val("");
				}).blur(function(){
					if (jQuery(this).val() === "") jQuery(this).val(searchvalue);
				});
			};

			/* footer widgets improvements */

			var $footer_widget = jQuery("#footer .footer-widget");

			if (!($footer_widget.length == 0)) {
				$footer_widget.each(function (index, domEle) {
					// domEle == this
					if ((index+1)%4 == 0) jQuery(domEle).addClass("last").after("<div class='clear'></div>");
				});
			};

			var $threaded_comments = jQuery('.depth-1 > ul.children');

			if ($threaded_comments.length) {
				$threaded_comments.each(function(index, domEle) {
					var $right_place = jQuery(domEle).parent('.depth-1').find('.entry-content');
					jQuery(domEle).appendTo($right_place);
				});
			}

					});
	//]]>
	</script>
				<script>
				// Used by Gallery Custom Links to handle tenacious Lightboxes
				jQuery(document).ready(function () {

					function mgclInit() {
						if (jQuery.fn.off) {
							jQuery('.no-lightbox, .no-lightbox img').off('click'); // jQuery 1.7+
						}
						else {
							jQuery('.no-lightbox, .no-lightbox img').unbind('click'); // < jQuery 1.7
						}
						jQuery('a.no-lightbox').click(mgclOnClick);

						if (jQuery.fn.off) {
							jQuery('a.set-target').off('click'); // jQuery 1.7+
						}
						else {
							jQuery('a.set-target').unbind('click'); // < jQuery 1.7
						}
						jQuery('a.set-target').click(mgclOnClick);
					}

					function mgclOnClick() {
						if (!this.target || this.target == '' || this.target == '_self')
							window.location = this.href;
						else
							window.open(this.href,this.target);
						return false;
					}

					// From WP Gallery Custom Links
					// Reduce the number of  conflicting lightboxes
					function mgclAddLoadEvent(func) {
						var oldOnload = window.onload;
						if (typeof window.onload != 'function') {
							window.onload = func;
						} else {
							window.onload = function() {
								oldOnload();
								func();
							}
						}
					}

					mgclAddLoadEvent(mgclInit);
					mgclInit();

				});
			</script>
		<script type='text/javascript' src='https://localheadlinenews.com/wp-includes/js/comment-reply.min.js?ver=b261fbcf7c892563c5f10e7924fb6b8e' id='comment-reply-js'></script>
<script type='text/javascript' id='clicktrack-adrotate-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/localheadlinenews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://localheadlinenews.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script type='text/javascript' id='theme-my-login-js-extra'>
/* <![CDATA[ */
var themeMyLogin = {"action":"","errors":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://localheadlinenews.com/wp-content/plugins/theme-my-login/assets/scripts/theme-my-login.min.js?ver=7.1.3' id='theme-my-login-js'></script>
<script type='text/javascript' src='https://localheadlinenews.com/wp-content/themes/Magnificent/epanel/page_templates/js/fancybox/jquery.easing-1.3.pack.js?ver=1.3.4' id='easing-js'></script>
<script type='text/javascript' src='https://localheadlinenews.com/wp-content/themes/Magnificent/epanel/page_templates/js/fancybox/jquery.fancybox-1.3.4.pack.js?ver=1.3.4' id='fancybox-js'></script>
<script type='text/javascript' id='et-ptemplates-frontend-js-extra'>
/* <![CDATA[ */
var et_ptemplates_strings = {"captcha":"Captcha","fill":"Fill","field":"field","invalid":"Invalid email"};
/* ]]> */
</script>
<script type='text/javascript' src='https://localheadlinenews.com/wp-content/themes/Magnificent/epanel/page_templates/js/et-ptemplates-frontend.js?ver=1.1' id='et-ptemplates-frontend-js'></script>
<script type='text/javascript' src='https://localheadlinenews.com/wp-includes/js/wp-embed.min.js?ver=b261fbcf7c892563c5f10e7924fb6b8e' id='wp-embed-js'></script>

</body>
</html>